Check here any time for the status of Dexcom services listed below. Note: not all services apply to all customers.

Follow Push Notifications are being delayed
Incident Report for Dexcom Incident Notification
Resolved
Full service of the Follow app has been restored. We know you rely on Dexcom and we apologize for any inconvenience. If you continue to have issues, please contact our Global Technical Support for assistance.
Posted Jan 27, 2023 - 20:58 PST
Update
We are still working on it. New updates will be posted here until service is restored.
Posted Jan 27, 2023 - 18:35 PST
Update
We are still working on it. New updates will be posted here until service is restored.
Posted Jan 27, 2023 - 16:52 PST
Update
We are still working on it. New updates will be posted here until service is restored.
Posted Jan 27, 2023 - 12:48 PST
Update
We are still working on it. New updates will be posted here until service is restored.
Posted Jan 27, 2023 - 09:37 PST
Update
We are still working on it. New updates will be posted here until service is restored.
Posted Jan 27, 2023 - 07:28 PST
Investigating
Follow App is receiving real time CGM readings when open but is not receiving real time push notifications. Push notifications are being delayed by 2 hours or more
Posted Jan 27, 2023 - 05:34 PST
This incident affected: Follow App (United States - Follow App).