Check back here any time for the current status of the Dexcom services listed below. Note: not all services apply to all customers.

Performance Issue - CLARITY
Incident Report for Dexcom Incident Notification
Resolved
Full service of Dexcom CLARITY has been restored. We know that you rely on Dexcom and we apologize for any inconvenience you may have experienced during this incident. If you continue to have issues, please contact our Global Technical Support directly at (844) 607-8398 for further assistance.
Posted Jul 21, 2021 - 20:34 PDT
Update
We are aware some customers may be experiencing service interruptions and are working on it.
Posted Jul 21, 2021 - 18:03 PDT
Identified
We’re still on it. We will continue to post updates here until full service is restored.
Posted Jul 21, 2021 - 16:03 PDT
Investigating
We’re still on it. We will continue to post updates here until full service is restored.
Posted Jul 21, 2021 - 16:02 PDT
Update
We’re still on it. We will continue to post updates here until full service is restored.
Posted Jul 21, 2021 - 13:32 PDT
Identified
We are aware some customers may be experiencing service interruptions and are working on it.
Posted Jul 21, 2021 - 11:20 PDT
This incident affected: CLARITY (United States - CLARITY, Outside United States - CLARITY).