Check here any time for the status of Dexcom services listed below. Note: not all services apply to all customers.

Performance Issue - G6 App
Incident Report for Dexcom Incident Notification
Resolved
This incident has been resolved.
Posted May 02, 2024 - 17:05 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 02, 2024 - 00:20 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 01, 2024 - 20:13 PDT
Investigating
We are aware some customers may be experiencing service interruptions and are working to resolve the issue.
Posted May 01, 2024 - 16:50 PDT
This incident affected: Follow App (United States - Follow App) and G6 App (United States - G6 App).