Check here any time for the status of Dexcom services listed below. Note: not all services apply to all customers.

Performance Issue - Clarity
Incident Report for Dexcom Incident Notification
Resolved
Full service of Dexcom Clarity has been restored. We know you rely on Dexcom and we apologize for any inconvenience. If you continue to have issues, please contact our Global Technical Support for assistance.
Posted Oct 15, 2024 - 13:57 PDT
Investigating
We are aware some customers may be experiencing service interruptions and are working to resolve the issue.
Posted Oct 15, 2024 - 11:38 PDT
This incident affected: Clarity (United States - Clarity).