Check here any time for the status of Dexcom services listed below. Note: not all services apply to all customers.

Performance Issue - G7 App
Incident Report for Dexcom Incident Notification
Resolved
This incident has been resolved.
Posted Mar 29, 2024 - 11:24 PDT
Investigating
We are aware some customers may be experiencing service interruptions and are working to resolve the issue.
Posted Mar 29, 2024 - 10:59 PDT
This incident affected: G7 App (United States - G7 App, Outside United States - G7 App).