Check here any time for the status of Dexcom services listed below. Note: not all services apply to all customers.

To check your country's server, click here.

Degraded Performance - Follow App and Stelo Insights - Push Notification Prod US

Incident Report for Dexcom Incident Notification

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 17:29 PDT

Investigating

Customers experiencing service interruptions with follow app and stelo insights push notifications in US
Posted Mar 18, 2025 - 17:08 PDT
This incident affected: Follow App (Server 1 - Follow App) and Stelo App (Server 1 - Stelo App).