Check here any time for the status of Dexcom services listed below. Note: not all services apply to all customers.

To check your country's server, click here.

Clarity Latency
Incident Report for Dexcom Incident Notification
Resolved
This incident has been resolved.
Posted Jul 29, 2024 - 08:15 PDT
Investigating
We are currently investigating this issue.
Posted Jul 29, 2024 - 07:27 PDT
This incident affected: Clarity (Server 1 - Clarity).