Check here any time for the status of Dexcom services listed below. Note: not all services apply to all customers.

Performance Issue - User Registration
Incident Report for Dexcom Incident Notification
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 22:16 PDT
Update
We are continuing to investigate this issue.
Posted Apr 22, 2024 - 22:07 PDT
Update
We are continuing to investigate this issue.
Posted Apr 22, 2024 - 21:38 PDT
Investigating
We are aware some customers may be experiencing service interruptions and are working to resolve the issue.
Posted Apr 22, 2024 - 20:13 PDT
This incident affected: User Registration (United States - User Registration, Outside United States - User Registration, Japan - User Registration).