Check here any time for the status of Dexcom services listed below. Note: not all services apply to all customers.

To check your country's server, click here.

Clinic uploads delayed
Incident Report for Dexcom Incident Notification
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 22:32 PDT
Investigating
We are currently investigating this issue.
Posted Mar 26, 2024 - 21:18 PDT
This incident affected: Clarity (Server 2 - Clarity).