Check back here any time for the current status of the Dexcom services listed below. Note: not all services apply to all customers.

Prod US Follow Notifications
Incident Report for Dexcom Incident Notification
Resolved
Full service of the Follow app has been restored. We know you rely on Dexcom and we apologize for any inconvenience. If you continue to have issues, please contact our Global Technical Support for assistance.
Posted May 10, 2022 - 11:10 PDT
Update
We have resolved this issue.
Posted May 10, 2022 - 11:07 PDT
Investigating
We are currently investigating this issue.
Posted May 10, 2022 - 08:34 PDT
This incident affected: Follow App (United States - Follow App).