Check here any time for the status of Dexcom services listed below. Note: not all services apply to all customers.

Production Issue - The Dexcom CLARITY Application
Incident Report for Dexcom Incident Notification
Resolved
Full service of the Dexcom CLARITY Application has been restored. We know that you rely on Dexcom and we apologize for any inconvenience you may have experienced during this incident. If you continue to have issues, please contact our Global Technical Support directly at (844) 607-8398 for further assistance.
Posted Apr 08, 2020 - 08:43 PDT
Investigating
The Dexcom CLARITY Application is experiencing degraded performance. Dexcom is aware of the issue and is actively working on a resolution. We will continue to post updates here until full service is restored.
Posted Apr 08, 2020 - 07:30 PDT
This incident affected: Clarity (United States - Clarity, Outside United States - Clarity).